get_iplayer seems to have stopped working for Radio Cymru

I was very disappointed today to realise that get_iplayer had stopped working for Radio Cymru. It still works for Radio 4 and Radio 4 Extra. However, I’m pretty sure something has changed because the filename created from the latter two stations is now in a different (and less helpful actually) format to previously - but at least it/they work.

There used to be something different about RC output anyway, since that always came out (handily) in MP3 output, but Radio 4/4 Extra came out in M4a, which might have to be converted to MP3 for some MP3 players. (Usually not a problem to play on a computer though).

I don’t want to say too much more here, since it is very much not an official facility, but if any techy types have any ideas, or if anyone has any background information, & would like to contact me by PM or email, then I’d be pleased to hear from them.


It seems the Beeb did in fact make changes recently.

The good news is that a new version seems to cope. (Version 2.90).
Feel free to PM / email me if you need help, or just google for get_iplayer 2.90 or 2-90

The new version didn’t work for me. I had to flag the issue; which was solved by a patch linked to from here:

Diolch Rob.

Well, version 2.90 has worked for me for at least one programme on RC.
(Edit: This was on Windows XP).

There are some “gotchas” however.
Feel free to PM or email me if you wish to compare notes.

Otherwise, let google be your friend.


EDIT: I spoke too soon. One programme was ok, but another keeps downloading incomplete. Having seen your link, I think I have the same or similar problem. Will PM you Rob to check.

Diolch i ti Rob for the link.

Have tried the fixed version and it’s much better.

(Only slight thing is that it now produces an m4a file. I always used to end up with mp3 files from RC output, but m4a output from R4 or R4 Extra, for some reason. No problem with m4a on the computer, but I don’t think my mp3 player supports it. However, not too difficult to convert, and I think I noticed an option somewhere in get_iplayer to do it on the fly (–aactomp3 or similar? ).

Yes, I think that the Nations radio stations were anomalous in producing mp3 files prior to the change, and this just brings them into line. I don’t have a problem with switching to m4a which my Android phone is happy to play and which seem to download much more quickly in any case.

Yes,I think that explains it.

And I also find m4a downloads faster. However, the --aactomp3 option to download as mp3 seems to work like a charm so far, so people have the option there if they want it. Does take longer though.