Can't download course 2 for Android

this may appear in an inappropriate place on the forum but my computer has blown so am using my mobile and can’t locate a ‘post’ button for some reason.

I downloaded the new course 1 onto mobile with no problems (fine course and hugely better than the old course in my opinion). However I can’t get the available lessons of the new course 2 to download. When I click to download, a very brief flash of ‘downloading’ appears under the cloudlike icon and immediately disappears leaving the same icon rather than it changing to a different icon as it does when a lesson is downloaded in new course 1. Has anyone had the same problem or can offer an explanation? If it’s of any import, I’m using an LG G3 with Lollipop.

Maybe one of the moderators will move the post to its own topic…

I suspect you have out of data course data. Refresh using the double circular arrow icon at the top of the screen, and then try downloading again.

The app should tell you to do this, but obviously that bit’s not working as it should

1 Like

Spot on Blacksparrow! Did as you suggested and the programs downloaded. Thanks very much for the solution.
Best regards,

1 Like

One to add to the known issues post!

Not to mention the bug list…

1 Like

Hi, I am also having problems with course 2 on my phone. Level 1 worked fine but course 2 just says no lessons available - however when I look on my computer I can access the course 2 lessons. I have tried refreshing it. What silly thing have I done now?

If there’s no lessons available for course 2 it’s very likely you’ve not entered your account details.

Go to the settings screen (via your menu button or the 3 little dots in the top right of the app) and from there you can login.

1 Like

Thank you. Sorry for being thick. I have eventually found the settings but now can’t work out what my details are as I usually just click on facebook. Is it the name + password from fb?

I should apologise. That error page should have more information on it…

You can try entering your facebook username and password, but I think that it’s unlikely to work.

I don’t know how the saysomethingin website handles logins using facebook details. I’ve asked the question, so I’ll update you when I know more.


1 Like

All sorted thanks James. I tried my SSIW username but that doesn’t work. In the end it was the fb email and password.

Good news. And good to know!

I downloaded the App onto my android yesterday and have done lesson 1 of course 1. I went onto the website to take a more detailed look and there I created a log in and user name. Now when I go to use these details on my android to access course 2, I’m getting a message to say ‘either you are signed in with a non-member account, or you have signed in with this account on another device’. I have tried signing out on line and then logging in on android but still getting the same message.
Many thanks in ancitipation of your help.

Have you signed up for a subscription to gain access to Course 2 and beyond?

1 Like

Ah, no! I’ve looked this up on the website now. That explains that. I’m jumping the gun a bit but am already enjoying the format of this course. Dw i’n licio siarad Cymraeg! Thanks for your help.

Now I’m nearing the end of course 1, I wanted to download course 2 to the ssiw app on my android device. course 2 wasn’t available, so i signed on with my account details. The lessons are still unavailable, error message that I have logged on with another device, [my desktop PC], this still happens when i have logged off from my PC, help.

Thanks for letting us know! @theblacksparrow is the man to solve this… :sunny:

You need to sign in again on your Android device.

You’ll need to go to the Settings screen and re-enter your password

1 Like

I’ve tried signing in on the phone again, with the same error messages.

What message do you get when you go to the Settings screen, and then choose the Logon details option and logon?

The top message on the settings screen is : Logon details, Signed in as y_ddraig_las.
If I tap into the Logon section, I can re-enter my username and password. It then says I have logged on successfully. When i try to update the content i get thsi message: “Could not refresh member only content. Either you are signed in with a non-member account, or you have signed in with this account on another device”

1 Like

Do you have access to course 2 with this account using the website?

i.e. can you go to this link and play the lessons?

1 Like