App problem for support team

I have had a great time upto lesson 22 course 1 which failed to download to my iPhone app. I deleted the app and reinstalled it but now I cannot sign in to the app( but I can to the full website) and cannot download any lessons to the app. The app is so much more friendly than the website. I am getting desperate. Can you help?
Declan Ryan (North )

Thanks for bringing this in here, Declan - one of our techier guys has just suggested to me that this might be connected to a question mark we’ve got today about one of our security certificates - if that is the case, then it’s possible that we’ll have this sorted by tomorrow (the certificate is going to be updated as soon as our developer is online).

But I’m a little puzzled about the sign-in issue - can you tell me what you see, or what error messages you get, when you try to log in to the app?

Hi, I’m using an iPad and have used the app for some time but I just found that it was missing and downloaded and installed it again but none of the lessons will download at all - just reports that the download has failed. Any solutions please? thanks

Hi Gwyneth - sorry for the frustration - we’re trying to find out if this is a security certificate issue - if it is, we should be okay in the near future - if not, we might need to try and ask some more troubleshooting questions! Very sorry again for the pain-in-the-neckness.

thanks for the reply and I will watch and wait

1 Like

Thanks Aran
I am glad to hear that there might be a reason. I tried to log into the APP under settings but was told it failed and to check my internet connection and details. I can log in to the full site no problem. I tried to re register as a new client, deleted the app reinstalled it and tried again but got the same response.

Hi all - we think this was a security certificate issue, which should now be resolved. Please try again - you shouldn’t need to reinstall the app for this (but it never hurts to try that if you’re having problems).

(Slightly technical explanation - remember the old URL that we used to use? Well, we didn’t renew the certificate for that because we don’t use it any more, but it seems as though the app was still using that URL, so I had to buy a new cert.)

Thanks again Aran,
The problem is partially resolved. I can now download lesson 21 and 23 but not 22 24 25 or 26! I will be okay for a few days but will need another fix by the weekend! I do hope that you can supply one…no pressure!!

I just managed to download all these lessons on to my iPhone with the app. Could it be something at your end, e.g. available space on your phone? Do you receive any warning or error messages when you try to download? settings->general->usage shows total available storage, the usage tab there shows storage usage by app. Those 6 lessons took about 145MB on my phone, by the looks of it.

1 Like

Good thought Louis, but no unfortunately loads of space! I am at a loss because it was seamless last week. Now I managed to download 23 but nothing else. I still cannot log in to the app.

Now I have registered as Declan2 but I am the same person as declanryan ! It just adds to the confusion and points worryingly towards me!!

I’m not sure what might be going on here, Declan - some kind of an issue with logging on, perhaps? I’m going to point Ifan at this thread in case he can think of anything (although I have just loaded him with a lot of time sensitive work on our new course creation tool, so please forgive him if he’s a little distracted!)… :sunny:

Thanks for all your efforts Aran. I seem to be able to log on to the web site with no problem. I use the same user name and password for the app but it fails and I am asked to check internet connection and retry. I cannot download the lessons on my iPhone or iPad apart from lesson 23 which I am looking forward to but after that I am lost!!

I can’t see how the certificate thing could cause only certain lessons to fail, so I don’t think it’s that. Have you tried reinstalling the app?

…and rebooted your phone…

The two usernames is a bit of a warning sign - and indeed it turns out that you have two different accounts, one for a Hotmail address and one for a Gmail address - do you know which your iPhone is trying to log in with?

I’m very sorry for the frustration. Can I confirm where we are right now - if you access the site directly (not via the app) you can download some lessons but not others - and with the app itself, you’re still not able to log in, with either of your accounts?

Thanks for getting back to me. Yes I tried to register a new account but it made no difference. I could only download lesson 23 course 1 N. Wales. Nothing else. I still cannot sign in to the app using either account or changing from iPhone to iPad. I can sign in to the website. I really want the app as it so friendly. Sorry about all this.

This is the really baffling bit - are you still getting the ‘check internet connection and retry’ error message?

I know it’s a pain in the neck, but could you try deleting and reinstalling again, and rebooting your phone? I’m thinking that the last time you did that might have been before we’d finished getting the security certificate okay - so it might work better now that we’ve done that.

Very sorry for the frustration you must be feeling with this. If it’s any consolation, I’m probably feeling almost as frustrated at not being able to fix it!

Thanks Aran
Yes I get a message instantly! ‘Download failed. Check internet connection and try again’. I will try deleting and rebooting again. Thank you for your efforts.

Declan Ryan

Thank you for not throwing your phone in the nearest lake and going on a ‘shouting angrily at Welsh speakers’ spree! I know what this kind of frustration is like, and I’m so sorry that we’re the cause of it for you at the moment. Fingers crossed hugely for the reinstall/reboot…