Android app testers for bug fixes required

A slight update to the Android app will shortly be available. It’s mainly bug fixes.

Here’s what’s in this version

  • Minor styling improvements to the current lesson playing widget on the lesson list screen
  • Bug fix to the login page so that it behaves correctly if the device is rotated whilst the login is happening
  • Added an option to settings to prevent the device going to sleep whilst the playback screen is active
  • Added an optional email prompt to the crash report dialog

It would be good to get a few more people switched over to this version. If you’d like to try it out, you’ll need to request to join this Google+ community

Once you’re a member, click on the link that says “Beta version” in the “About this community” section.

Diolch yn fawr


1 Like

Hi James, I’ve joined the community and clicked on the Beta version. I have the SSiW app already installed on my Android tablet. Does it mean that it will automatically update to the Beta version sometime in the near future? How will I realise it’s done that?

1 Like

You get Android notifications in the system tray thing about updated beta/alpha ups in the same way as you do for all other apps.

1 Like

What he said.

To check if you have the latest version

  • Load the app
  • Bring up the action bar menu (use your menu key, or click on the 3 dots in the action bar at the top)
  • Choose settings
  • Check that the version says 1.0.14

It says 1.0.11 so I guess I’m a few behind. Should I uninstall it and get the beta version?

What happens if you visit the app’s play store page from your phone?

It gives me the option to Open or Uninstall. When I click Open it opens up my current 1.0.11 version. I’m using it on a tablet rather than a phone. Does that make any difference?


if you visit this page, does it say that you’re a tester?

Yes :smile:

Let’s wait until tomorrow, and see if that helps.

Google are vague about how long it takes for new versions to be available once published

1 Like

OK, dim problem

1 Like

I’ve uninstalled app due to my space on the phone (it was 1.0.13) and installed it again and Google play installed 1.0.14 so it’s up to date.

Everything seams fine on my end. No bugs, no errors, screen doesn’t go to slumber when the “playing lesson page” is visible. For now it works perfectly.

Some special “area” of activities to be tested? :slight_smile:

1 Like

Well, I don’t know what the issue is with my tablet. I checked again this morning and it was still version 1.0.11 so I uninstalled it, went to PlayStore and installed a fresh version. Guess what? It’s still showing me 1.0.11! Why? It’s running Android 4.4.2 if that is any help.

And to compare I’ve just downloaded it from Play Store to my Samsung phone - it’s showing Version 1.0.11 as well :crying_cat_face:

Rotate the device when the login attempt is in progress

Go to the support bit in the settings screen and click “cause exception” to check if it asks you for an optional email address

Have you signed in to your phone with the same google account that you’re using when you visit

Aha, that just occurred to me as well. I thought I was but that tester link shows me that I’m logged in with an old google account. If I go to that link on my tablet which is my more recent google account and try again, maybe that will work.

1 Like

Oh boo! I tried on both my phone and my tablet, going into Google, selecting my old google account which is the one showing in the testing link above, uninstalled the old app, doublechecked I was in the right account and installed the app again. Both of them still show 1.0.11. It doesn’t look like I will be able to help, and I don’t understand why I’m not getting a later version.

Could you try joining the Google+ community using your new account?

Sorry James, I’ve tried that too. When I click on the link above it now shows that I’m a tester with my new Google account. I’ve gone back to my tablet, uninstalled SSiW, gone into Google and changed my account back to my new one again, reinstalled the app from Play Store and it’s still 1.0.11.

Maybe it’s not long enough after me registering my new account as a tester. I’ll try again later :smile: