Problem with SSi Spanish app on Android phone

I decided I need something to listen to when I’m out walking every day, so about a week ago I downloaded the SSi Spanish app to my Android phone with the intention of brushing up my Spanish.

It installed OK, but keeps saying “There was a problem getting hold of the latest course details” and giving me the option to send an Error Report. I dutifully do that, but nothing seems to happen; so I can’t use it.

Any suggestions?

1 Like

@jamesmahoney is the guy who’ll be able to figure this out… :slight_smile:


I will take a look


Wow! Superfast service! Muchas gracias muchachos :slight_smile:


I’ve uploaded a new version that should fix this issue.

It will likely take a few hours to be available on Google Play. Depending on your phone settings the update might be downloaded automatically.

If not, visit this link on your device, and choose to open it using the Play Store when it prompts you


Awesome work, James - diolch o galon i ti! :star: :star2: :dizzy:

Hi James, i think you asked me some while back to beta test this on Android. After it said it had installed there was no trace of it on my phone.
i don’t know what you just did, but it has now installed and works great (this on my aging Galaxy S2 [yes 2]) :O)
Unfortunately, i’ll be bootcamping this week, so won’t be allowed to use it !

1 Like

I’m back from bootcamp now and charging my phone so I can download it and have a go. Gracias, James! Fingers crossed :slight_smile:


Yay! It updated to the latest version!

Unfortunately I didn’t realise that my SSi membership doesn’t cover the app version, so I can’t go into Level 2 like I wanted by just logging in somehow, like I do with SSiW. It looks good for people that aren’t already website members though.

1 Like

Yeah, no membership access for the Spanish Android app yet.

However, since it’s in test mode, any purchase made via Google Play /should/ be free.

I thought I’d set this up for you.

What happens if you click on one purchase options? Do you see a Google Play purchase screen? It should say “this is a test purchase, you will not be charged”. (If it doesn’t then something hasn’t been set up correctly)

1 Like

Ah, I didn’t realise it was still in test mode.

I’ve clicked on the first challenge in Level 2, and I got the message about not being charged as it’s in test mode. I clicked to continue, and it is picking up a default email address and asking me for a Google password. Above that is the word ‘Paypal’ which is cut off. Does this want my PayPal email address and password? Or some other password?

I’ve tried entering the password that goes with the Gmail account it’s showing, but it doesn’t like that. I can’t enter my PayPal password, as the email address is not my PayPal one and it won’t let me change it.

So, I clicked on ‘Forgot password’ and went through the process of creating a new one with the email address that was showing. That all seemed to be successful, so I clicked back on the SSiSpanish app and it told me it had had a problem and asked me to send an error report, which I did.

After that, I went back into SSiSpanish and clicked to Buy Level 2 Challenge 1, went through with the new password, and everything worked fine. The lesson is playing!

1 Like

woo, google play purchase worked! (with only 1 crash! This bit of it’s very fiddly, and difficult to test properly, so diolch)

That popup is Android’s/Google’s. It’s showing the payment options you’ve set up (in this case Paypal).
It’s not a great screen, because it’s so tiny on some phones.
The cut off Paypal logo is probably down to the Play Store not correctly coping with your device’s screen or resolution.

Do you have access to lesson 2 as well, or just the first lesson?

1 Like

I’ve just had a play around and found that - after the first ‘purchase’ I had download clouds for lessons 1-10. I randomly chose Challenge 6 and it downloaded and played, though it didn’t start at the beginning. It started at the point that I had left Challenge 1, i.e. several seconds in. I clicked ‘Restart’ and it started from the beginning.

I then clicked on Challenge 11, which was showing a padlock. That sent me through the ‘purchase’ procedure again and gave me download clouds for Challenges 11 to 20. When I clicked ‘Play’ for Challenge 11 it started from the beginning, but I let it run for 20 seconds then went back to a previous Challenge that was already downloaded. It started from exactly 20 seconds in, so it’s holding that information and not resetting for a new Challenge.

I’m all set to revise my Spanish on my next walk though! Muchas gracias James!


Hi James, I cannot find the Say something in Spanish app in the Play store - is it still available?

I’m not sure if it’s still just in testing mode. @jamesmahoney hasn’t said anything about it going live. How’s it progressing, James?


What’s the Spanish for “like a puffin walking backwards up a very steep hill”?

@johnllevans PM me your Android/Google sign in email address and I’ll set you up with test access.


is it ‘Como un frailecillo caminando hacia atrás una colina muy empinada’?:slight_smile: i guess that it is proving to be a little difficult then?


Hi, James. I just tried to get the app on my Android phone. Can you set me up with test access (easier than than having to download the lessons, put them into Dropbox and then play from there!)? Ali x

1 Like

PM me your Android/Google sign in email address and I’ll set you up with test access.


Hi James
yes that has worked fine and all are downloaded - thanks.

I think that the 3 lines are quite common with Apps - i just was not aware that it had a refresh option - agree it may be worth referencing it in teh help FAQ section

thanks again


1 Like