IOS app

I’ve recently downloaded the app, but it won’t let me download any of the lessons!
Is anyone else having any issues?
Thanks :slight_smile:


what is happening when you try and download a lesson?

what lesson are you trying to download?

have you tried closing the app (double tap ‘home’ and swipe the app upwards) and then re-opening it?

1 Like

Sut dych chi!

It says ‘Download Failed, sorry but the lesson download failed. Please check your internet connection and retry.’

I know 100% there’s nothing wrong with the internet connection as I’m on wifi and have had emails coming through all morning! I’ve opened and closed the app a couple of times, even turned my phone off then back on but to no avail.

I’ve tried the wifi at home and at work, neither of them working :frowning:

Da Iawn, Diolch. Chi?

ok. which lesson is it that you are trying at the moment?

can you check you are signed in, maybe try signing out and back in.

I don’t have an IOS device handy so i’m going from memory so bear with me.

It gives me the same error message when I try and sign in! I switched from south Wales to north Wales and it downloaded the introduction but couldn’t go any further than that.

It gives you the same error when you try and sign in? That is strange.

Anybody who is using an IOS device having this issue?
I’ve just tried downloading on an android device and it works fine.

I will try on my iPad later and see if that’s any better, but thanks for your help Dan.

Diolch yn fawr i ti!

Dim problem, I’ll have access to an IOS device later this evening. I’ll try then as well.

Thanks very much for helping, Dan! :star: :star2:

Sam, very sorry for the frustration and inconvenience - I’m going to tag @lewie in here in case he can shed any light on it… :sunny:

1 Like

Under “Settings”, in addition to setting the region you also have to choose the Active Course. If that isn’t set, I get that download error. I’m not logged in.

1 Like

Right after fiddling with it, I’ve finally got some lessons downloaded, I changed the active course to something else then moved it back to the one I wanted then it sprang into life.

Diolch yn fawr pawb :slight_smile:


Oh, and just to let folks know, the new SSiW iOS app, which you may have heard rumoured about from time to time, has been submitted to Apple. It should surface sometime soon.


Fantastic news! Llongyfarchiadau a diolch o waelod calon! This should be a news item… :star: :star2: :fireworks: :heart:

Oh, and I see it’s available now! When I get a chance, I’ll put up a proper announcement, but for now, here’s a link:

1 Like

woo, and indeed, hoo.

1 Like

The app is great! I love the clean professional look. I signed in and have access to everything, have downloaded a couple of lessons and daily practices…all seems to work beautifully. Da iawn! Diolch yn fawr iawn!

1 Like

Helo! Jumping onto this very old thread to say that when I just got a new phone and re-downloaded the app, I’ve run into the same issue. It’s an Android, I’m logged in, and every time I try to download a lesson I get an error that there’s a problem with my network connectivity (which isn’t the case for any other app). I went into Settings but didn’t see an option for Active Course. Never run into this issue on previous Androids, either. Thoughts? Dw i angen bach o help, diolch!

ETA - I tried deleting and re-downloading and no dice

Hi @brennan

On that phone are you able to get to the Say Something In Welsh website via a browser - or see the forum in the App?

Rich :slight_smile:

Hi Rich,

Yes, if I click the “ask a question” link in the app it opens up the forum in a browser and I can log in and use it as normal.

Thanks for following up on this!


1 Like

If you’re having problems with an Android app, there is another thread where people have posted so you may wish to add your issue to that one:

With any luck our volunteer Android developer will see it there and give you a hand :slight_smile: