App issue

Hi all

Sorry to be a pain - I have searched on the forums, but couldn’t find the answer.

I’m currently on the six-month course and enjoying it. I use the app to do the challenges, but can’t access Level 2 as it’s premium content.

I logged out and back in using the account details I use on the website, but it still won’t alow me to use them.

I’d love to keep using the app, given its extra convenience, features etc.

While I’m here, can I just say how much I’m enjoying the course. I’m behind on badges and soundcloud stuff. I haven’t been organised enough to get into hangouts either, due to family reasons.

I’m up to date with challenges though, and now on Level 2. I’m able to listen to Radio Cymru and have a fair idea what’s being said, I speak Welsh with a colleague at one site I work at. Best of all though, I hold conversations in Welsh with my 80 year-old mum. This is a source of huge joy and keeps the brain ticking over for both of us (I grew up in South Pembrokeshire and never had a single Welsh lesson in school - I just absorbed some from family).


Hi @simon-rhys-phillips

The idea of having conversations with your mum sounds absolutely lovely :slight_smile: - and with practice opportunities at work too you sound like you are in a great situation to make very rapid progress. :sunny:

Which app are you using - iPhone or Android?

The pay wall is now at level 1, challenge 15 - so the fact that you have started to have problems at level 2 sounds strange - unless you’ve had all the level one challenges downloaded for some time (?) - do you have the latest version of the app downloaded?

Is there any danger of you having two accounts or you not being connected to the internet on the App?

There was a situation recently which sounds a bit similar where after @Deborah-SSi checked the account details on the system everything seemed to start working but of course that could also have been something else! :wink:

Rich :slight_smile:

1 Like

Hi Simon,

If you’re registered on the 6 Month course, then you definitely have access to Level 2 and it should be working in your app,

Are you using the iOS or the Android version?

If it’s iOS, you may find a solution here SSiW iOS app just updated or if not, you can leave a message there and get help with that.

If it’s Android, then this may help you Lessons not downloading on android or leave a message there for our volunteer Android developer.


1 Like

Firstly, thanks so much for taking the time to reply.

I’m on the iPhone. iOS and the app are up to date. I did have to update IOS and it seemed to work for a while, but now a lesson will go so far and just stop.

I logged out of the app and back in, but that didn’t help.

I also don’t think I can download lessons any more.

Sorry to be a pain, but I mostly use my phone for SSiW and the functionality of the app is useful.



Hi @simon-rhys-phillips

You can download still by holding your finger on the lessons for a bit longer until a download pop up appears - and then pressing it (see image below).

It does seem that the streaming is causing issues in some cases - it will be interesting to know if this fixes your problems.

Rich :slight_smile:


Oh yeah - I’m definitely logging with the details I used to register for the six-month course.

Personally I have had the odd issue where I have got a strange message and have seemed to be half logged in and half not eg I am logged in on the forum but have a problem with the lessons…

…so far I have found that going to to the settings page and logging out (by pressing the log out link - see image below) and then, on the same page, pressing log in…and entering your details, has solved this problem.

( Crashing our or exiting the App by contrast makes no difference. )

Let me know how you get on.

Rich :slight_smile:

1 Like

Hi Rich

Thanks so much for this.

I should have noticed that download method - I was used to seeing the big red download button where the play/pause button was.

I think it might play ok once download, but I’ll check.

Thanks again/diolch


Rich - just to mention that I’d tried logging out and back in from the settings screen a couple of times and still had the problem.

Seems there may be a few different quirks.

Thanks again for the help!


Just tagging @lewie here in case there’s anything he’d like to suggest to help :slight_smile:

1 Like

( no problem - are the lessons working after downloading? )

Simon - I assume that it’s playing OK once downloaded - yes? But also, if you go to a different lesson on Level 2 and try streaming it - does that now work?

1 Like


Thanks so much for the replies.

@lewie - it seems to work fine with downloading.

I tried streaming a couple of other lessons. One started about two minutes after I pressed the start button. The other hasn’t started after about five minutes.

I’m not too bothered, so long as I can download, but thought you’d want to know.

Thanks again


1 Like