The URLs for the site have been changed, to be much shorter and friendlier. (This was one of the prerequisites of the ongoing marketing project.) For example, everything for the SSiW community is now under /welsh, rather than the unwieldy /communities/welsh-for-english-speakers; the forum is at /welsh/forum; course 1 at /welsh/course1 and so on.

Before anyone worries about the old addresses no longer working - the old addresses should all redirect to the new ones, so there shouldn’t be any need to update your bookmarks or anything. (If however you do find any broken links, please come here to complain so I can fix it :))

If you don’t know or don’t care what any of this means, then don’t worry about it - everything should continue to work the same as before.

(Finally, sorry if any of you got caught up in the 5-minute period where everything broke - this URLs thing went beautifully when I did a dry run a week or so ago, but unfortunately turned out to break things for a few minutes this time!)


What about this URL?


Is it now doing a redirect as well?

The android app appears to be crashing because 200 OK isn’t being returned…

I can’t use the app on my iphone now. It keeps booting me out when I try and choose my course settings. I’ve deleted and reinstalled but to no avail.

Thanks for the heads up on this, folks - looks like an unforeseen nasty consequence, so I’m sure Ifan will be on the case today…:smile:

A little bit more info.

This URL works okay - https://site.saysomethingin.com/api/v1/communities/welsh-for-english-speakers

It’s the URLs inside it (such as https://site.saysomethingin.com/api/v1/communities/welsh/courses/course1) that the apps use to get the lesson content that no longer work.

They’re now returning
HTTP/1.1 422 Unprocessable Entity
{“message”:“Community not found”}

Brilliant, diolch yn fawr iawn iawn for that extremely useful detective work, James! :seren:

Nice one James! I did check the app on my iPhone and it seemed to work - well, I was able to download a lesson and play the start of it, but to be honest I never really used the app much so I’m not sure what’s supposed to happen.

Anyway, course, lesson and page URLs should now be fixed :slight_smile:

They’re returning data now, but the Android app is still crashing.

I’ll need to investigate further. This is unlikely to happen until tomorrow though

I’ve just tried opening my app on my iPhone and it worked fine. I even managed to download 3 more lessons no problems. Then, I went to the online page. It loaded up, but the community was unavailable. I then tried to select the settings page…and it crashed! I’ve tried to reopen the app and it just closes again. I cannot get into the app at all now!
I think it had something to do with the online page. I’ve been able to go between the settings and lessons pages with no problems up to a minute ago. Now I can’t open the app! :frowning:

Edit: I’ve just tried deleting the app and reinstalling. The app opens and defaults to the North course. But, as soon as you select the settings tab it crashes. Then you try to reopen the app and it immediately closes again, so it must be something to do with the Settings tab

Thanks very much indeed for that detailed feedback, Gavin - looks as though we’re going to need to try and get a conversation to happen between Ifan and Andrew - fingers crossed it won’t be all that long…

I suspect the problems are caused by a change to the JSON format for lesson data

It used to start

“title”:“Course 1”,


Now it’s:

“title”:“Course 1”,


It’s that missing identifier that’s important. The Android app uses this as its key when identifying a course.

The identifier for individual lessons also appears to have vanished too

Great detective work, James, diolch o galon i ti…:seren:

I’m having a similar problem listening to SSIW on my I-pod. I haven’t been able to open the app for the past day or so and before that it wasn’t retaining downloaded lessons once I clicked off the app. Can you help please?

Can you help please?

Thanks for letting us know, Lisa…:smile:

We’re doing our best to get this fixed - if we’re lucky, it’ll turn out to be a couple of lines that need fixing, but if we’re not, it could turn into a hunt the needle in the haystack job - so if you could hang on for the next couple of days, maybe using the site instead of the app, we’ll try and get everything in proper working order again as soon as possible…:smile:

Diolch Aran, bydda i’n keep trying!

How about now? The identifiers are now in the JSON and /mobile redirects to the right place. Hopefully should be OK now?

I’ve had to delete and reinstall the app, but it is now working properly again! I’ve tried all the links and downloaded my lessons again and we’re back in business! Diolch yn fawr iawn Ifan! Delighted

Is it possible to have the old course identifiers back?

They took the form “course-1-cyen” (it took me about 3 months to work out what cyen meant!). Now it’s just “course1”

It’s caused an issue in the Android app - all the courses appear twice because it thinks that course1 is different to course-1-cyen. Users can work around the issue by removing the app and reinstalling it.

(If you do that you will need to download all the lessons again. All of the usage data that records how many times you’ve done a lesson will also be lost).

Thinking long term, having globally unique course identifiers would make it easier to support have an app that supported Welsh, and Spanish, and French, and so on…

Eek, sorry about that. I’ll leave this for Ifan, but there’s a fighting chance we’ll not be going back on it, because it’s been a big part of making the urls more understandable.

Interesting point about multiple languages in one app - at the moment, I think I’d be more inclined to look in the direction of a separate app per language, not least for visibility purposes.

I’m keenly aware that we need to have a chat about going live with the Android app - but it might be better for everyone’s sanity until we wait for this round of web development to be over!