S4C International Website - Anyone else having trouble with subtitles?

Just wondering if anyone else is having the same problem…

Yesterday and today, when I try watch a program (any program) on the S4C International website, the subtitles don’t work. I’ve tried programs I’ve watched before with subtitles, but they don’t show anymore. I tried Rownd a Rownd tonight, and neither Welsh nor English subtitles show.

I’d appreciate knowing if somehow it’s just me, or if it’s a problem on their end…if any of you would be willing to see if it works for you, and let me know, I’d be very grateful. If it’s not working for others, then I’ll send S4C an email.

Diolch o flaen llaw!

They’re working fine for me Anna.

Thanks, Craig, I really appreciate your help. I don’t know why they have suddenly stopped working for me in Chrome on both a Windows 7 PC and a Windows 10 PC. They worked fine last week. Since I posted, I have found that they work in Chrome on my iPad, and I just tried Firefox (which I never use anymore) on the Windows 7 PC and I have them there. Totally stymied right now, but I’ve got to go to bed!

Odd, I used Chrome on Win 8.1. I didn’t know you could use it on Mobile now. So, I tried my Android tablet, and no option for subtitles there. I tried Firefox (no Flash plugin installed) but it seems HTML5 video doesn’t work for Desktop. Although the ad ran just fine. LOL


I finally figured it out. I have an ad blocker running on both PCs, and I when I turned it off for the S4C website, the subtitles started working. Now, I haven’t touched the adblock settings recently, and I don’t remember having turned it off to make this work in the past. I have no idea why anything would have changed over the weekend to mess things up!

I didn’t know the website worked on mobile now, either - it didn’t when I tried last summer. The Windows 10 PC doesn’t have flash installed for Firefox, and no video would play for me there, not even the ad. I tried the Edge browser, which I had not used before, and it will play the video but doesn’t give me an option for subtitles. No idea how all this stuff works! I’m just grateful that I had the inspiration to look at the ad blocker, because lots of Googling trying to figure out what on earth might be causing the problem wasn’t getting me anywhere. Now I can get back to work trying to improve my listening comprehension :slight_smile:

Thanks for your help!


As has been mentioned elsewhere, the situation with Clic and ads seems to vary over time. In recent weeks (or more) I had not noticed any. When I just looked at something to see if I could see subtitles ok (after reading your post), I noticed there was an ad I had to watch first.

So I wonder if it’s because they have re-introduced ads lately, and that’s why your adblocker was affecting things?

(I’m in the UK, by the way. BTW, subtitles don’t seem to work on my Android phone, even here in the UK, either using the website or the S4C app (which apparently is only available/usable in the UK. I could not get it to work on holiday abroad, even though it was already installed on my phone)


There are no subtitles on Clic for Android, even using the S4C app. There are subtitles for BBCiplayer S4C programmes, but only in English. I do get subtitles on Clic on the PC (Linux) (Welsh & English).
Android is Linux based, so it should be possible, someone just needs to update the software.

1 Like

What is Geo-restricted is geo-restricted no matter previously installed in “allowed” area. When you once go to “forbidden” one it doesn’t work anymore except for … well we won’t start about that on here again …

For the record I can’t get to work Dal Ati app prety much either for even what one could watch there so this is the wonderland I will still have to discover one day … And, yes, I just tried the website on my Android tablet. No subtiles though as @Y_Ddraig_Las says.

(automatic) Updates to the software make mess quite at some occassion so it migh tbe they’d alter the thngs for you, being them updates to browser or to Addblocker. For the nosy mind of mine, do you use ABP (AdBlocker Plus)? This one is the best what concerns me and my son told me it’s even recommended by Google itself in a way (despite they’re all adds and stuff themselved. :slight_smile: )

1 Like

It’s not clear though, why they do geo-restrict the app. I understand that they geo-restrict programmes (with the exception of those listed on their international page), but you would think that they would let you play the unrestricted programmes via the app, as well as via the website.

IIRC (and unfortunately, I can’t check this now), when I was in Lanzarotte, I was able to watch Rownd a Rownd (and a couple of other internationally available programmes) via the normal Clic website. I did not have to get to it via the international website.

Anyway, when I’m in the UK and can use the app, it is actually a bit better than using the website, at least on my phone, because you can get it to go full-screen and if I physically rotate the phone to “landscape” view, the picture expands to fill the entire physical screen. This does not seem to happen if I go via the website, where the picture remains a relatively small subset of the physical screen whatever I do.

@tatjana Yes, I use Adblock Plus. It works really well.

@mikeellwood I can make the video full screen on my iPhone from the website, using the little icon in the bottom right corner. No option to use the Clic app in the US :frowning:

1 Like

Aha, it’s working for me now! (on Android, as it happens) (including rotating the screen to landscape mode which makes full screen worthwhile).

Before I had ever tried it, I would not have thought it would be worth watching TV on a phone, even a biggish one, but it is surprisingly watchable. I suppose a tablet would be even better.

1 Like

I don’t understand that either, but I can’t even see it in Play Store what to download it onto my phone/tablet so it’s “perfectly” geo-restricted for who knows what reason. Will ask S4C one day if it would make it available now that International part of the program is on their website too.

Websites in a browser work prety much the same as on the PC at least for me so yes, little icon down the right side is very useful thing.


If they reply, please let us know what they say. I’ve found they are a bit more responsive than the BBC,but not every time. I asked what I thought was a reasonable question about their subtitles: they changed their player around the end of 2015, so it no longer showed the subtitles in different colours (to show different people speaking). Ironically, the BBC iPlayer still does have the colours (but it only has English, and not Welsh). Anway, I didn’t get an answer to that one.
(And unfortunately, I only got a stupid answer from the BBC as to why they didn’t show the Welsh ones - they tried to point me to S4C, when clearly what was needed was a (small) change to their (BBC’s) media player, to add an option for subtitles in more than language. But clearly they are not interested in doing this, and I can sort of see why).

Well, round about that time I decided to do without subtitles (or try to!), so it’s no longer a hot button for me.

Might include that one in. It cost me nothing but my hands to type. Let’s see what happens. :slight_smile:

1 Like

“I finally figured it out. I have an ad blocker running on both PCs…”

Thank you! I’ve been without S4C Rhyngwladol for a month (except, oddly, a few of the children’s programs). Firefox had been working nicely, with subtitles, and then something changed–nothing I did. When most of the programs start to load, a light gray screen comes down from the top and there’s no way to see anything. S4C techs started trying to help and I provided details of my set-up, but have heard nothing further for a week. They did suggest trying another browser.

I tried Chrome which worked but had no subtitles. Turning off the ABP adblocker for the site did the trick.


Croeso mawr! I’m happy my solution worked for you, too :slight_smile:

1 Like